A fix has been implemented and we are monitoring the results.
Posted Aug 30, 2026 - 11:04 BST
Investigating
Please be advised that we are currently experiencing a delay in applying early prices. We are working to get this resolved as quickly as possible. We appreciate your patience, during this time.
Posted Aug 30, 2026 - 09:12 BST
This incident affected: Data Feeds (BTC Data Feed).