BTC early prices

Incident Report for A Bet A

Resolved

Early prices are now available. We thank you for your patience.
Posted Oct 18, 2025 - 12:12 BST

Identified

We are continuing to investigate this issue. We thank you for your patience whilst we work on getting the early prices made available as soon as possible.
Posted Oct 18, 2025 - 11:02 BST

Investigating

Good morning, please be advised that there will be a delay in publishing the BTC early prices. We are working on this as a top priority and hope to have these available as soon as possible.
Posted Oct 18, 2025 - 09:31 BST
This incident affected: Data Feeds (BTC Data Feed).