No EP's

Incident Report for A Bet A

Resolved

Early prices are now available.
Posted Apr 12, 2026 - 09:22 BST

Investigating

Please be advised that there is currently an issues with receiving today's early prices. We are investigating this as a priority.
Posted Apr 12, 2026 - 09:18 BST
This incident affected: Data Feeds (BTC Data Feed).