BTC EP's

Incident Report for A Bet A

Resolved

This incident has now been resolved. The early prices should now be up to date.
Posted Apr 04, 2026 - 12:23 BST

Update

We are continuing to investigate this issue.
Thank you for your patience.
Posted Apr 04, 2026 - 11:53 BST

Investigating

Please be advised that we are currently experiencing an issue with the BTC ep's not updating. This is being worked on and a fix is being implemented. We will provide a further update as soon as possible.
Posted Apr 04, 2026 - 10:29 BST
This incident affected: Data Feeds (BTC Data Feed).