BTC Data Issues

Incident Report for A Bet A

Resolved

This incident has been resolved.
Posted Apr 03, 2026 - 19:03 BST

Identified

Sports content is not coming down from the server. A fix is being implemented
Posted Apr 03, 2026 - 18:37 BST

Investigating

We are currently investigating this issue.
Posted Apr 03, 2026 - 18:20 BST
This incident affected: Data Feeds (BTC Data Feed).