This incident has now been resolved and Betstream connectivity has been restored.
Posted Oct 08, 2025 - 09:10 BST
Investigating
We are currently experiencing an issue with Betstream licensing, which is preventing updates from being transmitted from your price providers. Our team is actively investigating and working to resolve the issue as quickly as possible.
We appreciate your patience and understanding while we work to restore normal service.
Posted Oct 08, 2025 - 08:00 BST
This incident affected: Data Feeds (TRP Data Feed, David Byrne Data Feed, Geoff Banks Data Feed, BTC Data Feed, SIS Data Feed).