BTC delayed price updates

Incident Report for A Bet A

Resolved

This incident has now been resolved.
Posted Aug 29, 2026 - 19:36 BST

Monitoring

We are continuing to monitor and investigate the ongoing delay with early prices, as price updates are still running slightly behind.

Please continue to refer to your BTC screens to ensure you are using the correct prices.

We will provide a further update once this issue has been resolved. Thank you for your continued patience and understanding.
Posted Aug 29, 2026 - 11:31 BST

Investigating

Following this morning’s issues with delayed event generation and early prices, we have been made aware that a delay may still be present for early prices.

We are currently investigating this and will provide a further update as soon as possible.

In the meantime, please refer to your BTC screens to ensure the correct prices are being used.

Thank you for your patience and understanding
Posted Aug 29, 2026 - 09:18 BST
This incident affected: Data Feeds (BTC Data Feed).