No BTC EP's
Incident Report for A Bet A
Resolved
This incident has been resolved. All EP's are now available.
Apologies for the inconvenience caused.
Posted May 25, 2021 - 14:32 BST
Investigating
Please be advised that we have not received any BTC EP's for today's racing. We are working with BTC to get these in place ASAP.
Posted May 25, 2021 - 11:40 BST
This incident affected: Data Feeds (BTC Data Feed).