Issues with email delivery

Incident Report for A Bet A

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 08:58 BST

Investigating

Mailgun have been contacted and they are investigating from their end.
Posted Oct 20, 2025 - 18:43 BST
This incident affected: Request A Bet (MailGun).