No prices for Catterick 17:51

Incident Report for A Bet A

Resolved

This incident has been resolved.
Posted Sep 08, 2026 - 21:24 BST

Update

Please note that this also effects No. 4 Momentsofsurrender in the 14:05 at Goodwood.
Posted Sep 08, 2026 - 12:37 BST

Update

Please note that due to a spelling error from BTC, there will be no price updates for No.7 Lizzie Bennet in the 13:12 at Leicester.
Posted Sep 08, 2026 - 09:52 BST

Investigating

Due to a misconfiguration of the data from BTC, there will be no prices available for the 17:51 at Catterick.
Posted Sep 08, 2026 - 09:16 BST
This incident affected: Data Feeds (BTC Data Feed).