BTC Horses and Dogs
Incident Report for A Bet A
Resolved
This incident has been resolved.
Posted May 22, 2022 - 10:36 BST
Update
We are continuing to investigate this issue.
Posted May 22, 2022 - 10:35 BST
Investigating
We are currently investigating this issue.
Posted May 22, 2022 - 10:15 BST
This incident affected: Data Feeds (BTC Data Feed).